【 WordPress 】 エラー対策 Warning: ~/wp-includes/query.php on line 2390

 4日ほど前から、Wordpress のメディアライブラリに以下のエラーが表示されて困っていたのだが、どうやら、これは WordPress 3.x.x のバグらしい。対応策には、Hotfix というプラグインをインストールすることで解決。

■ エラーメッセージ

  • Warning: explode() expects parameter 2 to be string, array given in /(Wordpressのディレクトリ)/wp-includes/query.php on line 2390

 ↑ このエラーがライブラリにダーッと表示されて大変なことに。プラグイン以外の対策として、query.php の一部を修正すればよいらしいけど、面倒なのでプラグインで対応。Wordpress が 4 にアップグレードするときに対策されるらしい。4 になったとき、プラグイン Hotfix を外すのを忘れないようにしないと……。

 

■ 対応プラグイン:Hotfix